Das OFFIZIELLE PROFAN SUPPORT FORUM
Einsteigerfragen
PROFAN-Programmierung
Helfer & Tools
Anregungen & Vorschläge
PROFAN-NEWS
Die Regeln!
1 - Einsteigerfragen

 Neues Thema  |  Zur Übersicht  |  Suchen  |  Einloggen   Neuerer Beitrag  |  Älteres Thema 
 Probleme mit Netzwerk
Autor: Klaus Vollrath (---.124.195.178.dynamic.wline.res.cust.swisscom.ch)
Datum:   06.06.20 17:58

Ich arbeite in meiner Wohnung mit mehreren Rechnern unter Windows und verwende XProfan 3.
Meine Rechner hängen alle an einer WLAN-Internetbox, an die über USB ein gemeinsamer Speicher (NAS, Network Attached Storage) angeschlossen ist. Jeder Rechner kann auf diesen Speicher zugreifen, so dass Datentransfer möglich ist. Von Hand funktioniert das einwandfrei, aber ich schaffe es nicht, Daten im Rahmen eines Xprofan-Programms zu übertragen. Es gibt dabei jedsemal den E/A-Fehler 104. Bleibe ich mit denselben Befehlen innerhalb eines Rechners, funktioniert alles einwandfrei.
Als Pfadangabe verwende ich "\\Internetbox-nas\usb2\..."
Kann mir jemand einen Tipp geben?

Beitrag beantworten
 
 Re: Probleme mit Netzwerk
Autor: Heinz Brill (---.dip0.t-ipconnect.de)
Datum:   07.06.20 07:32

E/A-Fehler 104 ist normalerweise ein Dateizugriffs-Fehler.
Evtl. ist die Datei von einem anderen Rechner geöffnet
und nicht wieder geschlossen worden.

Hast du auch schon mal mit einfachen oder doppelten Slashes
statt Backslash probiert ?

"//Internetbox-nas/usb2/..."

Kann es aber selber nicht probieren, da nur 1 Rechner vorhanden.

Vielleicht wissen die Netzwerkfachleute hier mehr.

PS: Wie bekommst du den Inhalt der Datei ?
Per FTP() oder mit den normalen Dateifunktionen ?

H.Brill
XProfan X4 + FreeProfan

Nachricht bearbeitet (07.06.20 08:24)

Beitrag beantworten
 
 Re: Probleme mit Netzwerk
Autor: Frabbing (---.dyn.telefonica.de)
Datum:   09.06.20 12:23

Deutsche Umlaute sind auch problematisch.

Gruß, Frank

In der Wut verliert der Mensch seine Intelligenz.



Beitrag beantworten
 
 Re: Probleme mit Netzwerk
Autor: Arndt Lindner (---.dip0.t-ipconnect.de)
Datum:   12.06.20 16:08

Ich verwende ebenfalls ein NAS im Netzwerk mit mehreren Rechnern. Dabei habe ich den Verzeichnissen im NAS jeweils Laufwerksbuchstaben zugewiesen und ich spreche die NAS-Verzeichnisse mit Hilfe der Laufwerksbuchstaben wie lokale Laufwerke an. Mit "diskfree" kann man abfragen, ob das NAS eingeschaltet und die Laufwerke von Windows eingebunden sind.



Beitrag beantworten
 
 Re: Probleme mit Netzwerk
Autor: Arndt Lindner (---.dip0.t-ipconnect.de)
Datum:   12.06.20 16:28

Nachtrag:
Verwende als Pfandangabe "\\\\Internetbox-nas\\usb2\ß...", dann müsste es auch funktionieren wenn das "ß" keine Problema macht.
Backslash wird auch für Ersatzzeichen verwendet und sollte deshalb doppelt angegeben werden (Siehe Profan-Hilfe, Tabelle Ersatzzeichen).



Beitrag beantworten
 Foren-Liste  |  Baumstruktur   Neuerer Beitrag  |  Älteres Thema 


 Foren-Liste  |  Zur Registrierung 
 Benutzerlogin
 Benutzername:
 Passwort:
 Login-Daten speichern:
   
 Passwort vergessen?
E-Mail-Adresse oder Username unten eingeben. Dann wird Dir per e-Mail ein neues Passwort zugeschickt.

phorum.org