Das OFFIZIELLE PROFAN SUPPORT FORUM
Einsteigerfragen
PROFAN-Programmierung
Helfer & Tools
Anregungen & Vorschläge
PROFAN-NEWS
Die Regeln!
1 - Einsteigerfragen

 Neues Thema  |  Zur Übersicht  |  Suchen  |  Einloggen   Neuerer Beitrag  |  Älteres Thema 
 Midi beleidigt
Autor: p. specht (---.aon.at)
Datum:   22.09.18 20:46

Irgendwie habe ich es "geschafft", die Ausgabe des MUSIC Befehl im Interpreter für mmer zu verstellen: Man hört nix. Compiliert klappt dagegen alles weiterhin.
Momentan kein Plan ... Hat das was mit MIDI-Gerät zu tun?

____
Ein richtiges Problem hat keine Lösung, nur Näherungen!

Beitrag beantworten
 
 Re: Midi beleidigt
Autor: Michael Wodrich (---.customer.vsm.sh)
Datum:   26.09.18 11:02

Wenn du unten das Lautsprechersymbol hast, dann "Optionen für die Lautstärke-Regelung". Dort alles richtig einstellen. Dann auf die Geräte mit grünem Häckchen Doppelklick und auch dort alles kontrollieren.

Gleiche Einstellung findet man unter Systemsteuerung - Sound

Ich habe auch noch einen Midi-Treiber, der extra aufgerufen werden kann. Auch dort kann man Einstellungen vornehmen. Hinter dem letzten Tab ist meist auch ein Testmodus zum direkt testen.

Kopfhörer nicht vergessen.
So mancher ist schon bitter am Lautsprecher verzweifelt, obwohl der Rechner doch alles artig an den Kopfhörer sandte...

Bei mir war es mal der Midi-Treiber, der eine Kleinigkeit verstellte...

--
Programmieren, das spannendste Detektivspiel der Welt.
Programmierumgebung: | XProfan (neueste) | Win (neueste)


Beitrag beantworten
 
 Re: Midi beleidigt
Autor: p. specht (---.aon.at)
Datum:   26.09.18 15:10

Danke, werde Punkt für Punkt nochmal alles abarbeiten.
Was mich wunderte: Interpreter nix, Compiler ok ?
Gruss

____
Ein richtiges Problem hat keine Lösung, nur Näherungen!

Beitrag beantworten
 
 Re: Midi beleidigt
Autor: p. specht (---.aon.at)
Datum:   03.01.19 20:44

Problem nach langer Zeit behoben! Geholfen hat https://xprofan.net/intl/de/quelltexte/api-midi-per-sound-wiedergeben-winmmdll/ dieses Programm von Jörg Sellmeyer, das eine Einstellungsmöglichkeit für verschiedene aufgefundene MIDI-Geräte enthält. War bei mir auf 0 gestellt im Interpreter , darum das Problem!

Gruss!

____
Ein richtiges Problem hat keine Lösung, nur Näherungen!

Beitrag beantworten
 Foren-Liste  |  Baumstruktur   Neuerer Beitrag  |  Älteres Thema 


 Foren-Liste  |  Zur Registrierung 
 Benutzerlogin
 Benutzername:
 Passwort:
 Login-Daten speichern:
   
 Passwort vergessen?
E-Mail-Adresse oder Username unten eingeben. Dann wird Dir per e-Mail ein neues Passwort zugeschickt.

phorum.org