Das OFFIZIELLE PROFAN SUPPORT FORUM
Einsteigerfragen
PROFAN-Programmierung
Helfer & Tools
Anregungen & Vorschläge
PROFAN-NEWS
Die Regeln!
4 - Anregungen & Vorschläge

 Neues Thema  |  Zur Übersicht  |  Suchen  |  Einloggen   Vorherige Nachricht  |  Nächste Nachricht 
 FOR mit globaler Variable in PROC funktioniert nicht?
Autor: Jens-Arne Reumschüssel (---.95.112.pool.telefonica.de)
Datum:   09.01.22 12:21

Hallo am Sonntag,

mir ist gerade ein sehr merkwürdiger Fehler aufgefallen:

FOR mit einer global definierten Laufvariablen scheint nicht zu funktionieren. Allerdings nur in PROCs; im Hauptprogramm geht es. Ein Beispiel

 declare i&,o&
 
 proc test
   i&=1 'das funktoniert
   while i&<=10
     inc i&
   endwhile
   for i&,1,10 'das funktioniert nicht
   endfor
 endproc
 
 for o&,1,10 'das funktioniert
 endfor
 test
 end
 

Interpreter und Compiler melden, die Variable i& sei nicht deklariert, was offensichtlich nicht stimmt.

Beste Grüße, Jens-Arne



Nachricht bearbeitet (09.01.22 12:23)

 Beitrag beantworten  |  Foren-Liste  |  Alle Antworten   Neuerer Beitrag  |  Älteres Thema 

 Beiträge Autor  Datum
 FOR mit globaler Variable in PROC funktioniert nicht?  Neu
Jens-Arne Reumschüssel 09.01.22 12:21 
 Re: FOR mit globaler Variable in PROC funktioniert nicht?  Neu
Arndt Lindner 09.01.22 15:40 
 Re: FOR mit globaler Variable in PROC funktioniert nicht?  Neu
Jens-Arne Reumschüssel 09.01.22 16:07 


 Foren-Liste  |  Zur Registrierung 
 Benutzerlogin
 Benutzername:
 Passwort:
 Login-Daten speichern:
   
 Passwort vergessen?
E-Mail-Adresse oder Username unten eingeben. Dann wird Dir per e-Mail ein neues Passwort zugeschickt.

phorum.org