Das OFFIZIELLE PROFAN SUPPORT FORUM
Einsteigerfragen
PROFAN-Programmierung
Helfer & Tools
Anregungen & Vorschläge
PROFAN-NEWS
Die Regeln!
2 - PROFAN-Programmierung

 Neues Thema  |  Zur Übersicht  |  Suchen  |  Einloggen   Neuerer Beitrag  |  Älteres Thema 
 Mailversand CL32.dll DLL wird nicht geladen?!
Autor: Axel Berse (---.briteline.de)
Datum:   18.10.21 05:27

Hallo zusammen,

ich versuche auf 2 verschiedenen Rechnern den Mailversand zu nutzen.
Folgender Code mit identischer XProfan X4 Konfiguration funktioniert auf dem Windows Server 2016 aber nicht auf meinem Windows 10 Pro 20H2

Print UseDll("cl32.dll") ' Hier kommt schon ein Zugriffsfehler das die DLL nicht geladen werden kann.

Set("SMTPSSL",1)
Print "§$§ Mailversand"
print smtp("SendMail", "aberse@gmx.de", "aberse@gmx.de","TestMail", "mail.gmx.net:587","aberse@gmx.de","*******","Diese Mail kommt aus XProfan und ist kein SPAM!!!!") ' Hier kommt ebenfalls der Fehler das die DLL nicht gefunden wird.

WaitInput

2. Es gibt eine neue CL32.DLL von Peter Gutmann (3.4.5.0) diese kann aber augenscheinlich nicht einfach verwendet werden, da sich vermutlich interne Strukturen verändert haben.

Um nicht mit externen Tools rumzuhantieren (Was auch geht...) würde ich es bevorzugen wieder intern Mails versenden zu können.
Außerdem wäre da noch die Frage nach TLS 1.2 / 1.3. was wird unterstützt?
Bei unserem Exchange Server wurde in der vergangenen Woche ein Security Update eingespielt.
Das hatte die Abschaltung der TLS 1.0 / 1.1 zur Folge.
Mit dem Ergebnis das diverse Programme ihren Dienst einstellten....


Anregungen gerne wie das DLL Problem gelöst werden könnte.
Außerdem Antworten zur Einbindung der neuen DLL herzlich willkommen ;)

Viele Grüße

Beitrag beantworten
 
 Re: Mailversand CL32.dll DLL wird nicht geladen?!
Autor: Heinz Brill (---.dip0.t-ipconnect.de)
Datum:   18.10.21 08:07

Welche XProfan - Version nutzt du ?
Normalerweise brauchst du die CL32.DLL gar nicht zu laden.
Die muß nur im Programmordner bzw. Profan-Ordner existieren.

Die wird mit Set("Smtpssl", n) automatisch geladen.
Und schau mal, was für einen Port dein Standardprogramm
für den Postausgang benutzt.

Ich glaube, da gab es bei gmx auch Probleme. Seit man Zertifikate
braucht, ist das sowieso etwas problematisch.

Bei mir geht es neuerdings bei t-online auch nicht mehr.

Da geht es nur mit versuchen.

H.Brill
XProfan X4 + FreeProfan

Beitrag beantworten
 
 Re: Mailversand CL32.dll DLL wird nicht geladen?!
Autor: Axel Berse (---.briteline.de)
Datum:   18.10.21 08:20

Moin Heinz,

schön von dir zu hören!
Ja mit GMX gibt es Probleme obwohl ich in den Einstellungen bei GMX den Appzugriff erlaubt habe.

Ja die DLL muss man normalerweise nicht laden, das habe ich gemacht um zu gucken woher der Fehler wohl kommen könnte.
Deswegen auch der minimalistische Quellcode ;)

Ports habe ich alle verdächtigen in allen Kombinationen ausprobiert. 465,587,25
mit set(smtpssl, 1 und 2) ;)

Das DLL Ladeproblem scheint was mit meinem Windows 10 Pro zu tun zu haben.
Werde das noch mal mit einer VirtualBox ausprobieren.

Es wäre echt schön wenn das generelle Mailversenden ohne viel gefummel wieder funktionieren würde.

Aber das wird wohl wegen der Zertifikate nicht mehr so einfach?!?
Damit habe ich mich noch nicht beschäftigt.

Viele Grüße

Beitrag beantworten
 Foren-Liste  |  Baumstruktur   Neuerer Beitrag  |  Älteres Thema 


 Foren-Liste  |  Zur Registrierung 
 Benutzerlogin
 Benutzername:
 Passwort:
 Login-Daten speichern:
   
 Passwort vergessen?
E-Mail-Adresse oder Username unten eingeben. Dann wird Dir per e-Mail ein neues Passwort zugeschickt.

phorum.org